Megjelent a Wine 3.0

kami911 képe

Ha Linux alatt szükség van Windows alkalmazok futtatására, akkor a Wine vagy a belőle készült termékekkel teheti meg azt a felhasználó, x86 utasításkészlettel rendelkező számítógépeken. A Wine új kiadása, hosszú fejlesztési fázis után került immáron végleges verzióban a publikum elé. A 6000 módosítást tartalmazó köztes réteg, azaz wrapper, nem egy emulátor (erre utal a neve is: WINE – Wine Is Not Emulator), így nem teljes gépet emulál a gépben futó alkalmazásnak, mint mondjuk virtualizáció esetén, hanem az alkalmazott rendszerhívásokat fordítja le a megfelelő linux-os, mac-es hívásokra.


Újdonságok

  • Direct3D 10 és 11 támogatás,
    • Compute shaderek
    • Tesszelációs shaderek
    • Shader modell 4 és 5
  • A Direct3D parancsfolyam támogatás,
    • Többszálú parancsfolyamok, a leképzés tökéletességéért és a jövőbeni teljesítmény növeléséért - alapértelmezetten ki vannak kapcsolva.
    • Több grafikus kártyát ismer fel a Wine.
  • Android grafikus illesztőprogram,
  • Továbbfejlesztett DirectWrite és Direct2D támogatás.
  • Kernel
    • Alapértelmezett Windows verzió a WIndows 7-es.
    • Soros és párhuzamos portok automatikus felvétele.
  • Számos további újdonság - érdemes átnézni a kiadási megjegyzéseket!

Új HKCU\Software\Wine\Direct3D registry kulcs

"csmt" (REG_DWORD)

Bekapcsolva: (0x1) kikapocsolva: (0x0, default) a többszálú parancsfolyamok

Támogatott alkalmazások listája: Wine Application Database (AppDB)– Itt ellenőrizhetők a Wine alatt futtatható alkalmazások

A Wine 3.0 kiadási megjegyzései

Letöltés és telepítés

A legújabb 3.0-s verzió letölthető innen.

Linux Mint alatt a következő módon telepíthető a Wine 3.0: Adja hozzá a i386-os rendszerarchitektúra támogatását 64 bites Linux Mint (vagy Ubuntu) esetén:

sudo dpkg --add-architecture i386

Fontos: Az eddig PPA csomagtárolóból történő telepíté helyett a winehq.org saját csomagtárolójából telepíthetőek a szükséges csomagok.

Stabil Wine kiadás telepítése

A stabil Wine telepíthető csomagtárolóból a következő tároló hozzáadásával Szoftverforrásokban:

https://dl.winehq.org/wine-builds/ubuntu/

majd a „wine-stable” csomag telepítésével, vagy parancssorból a következő parancsokkal:

wget https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/'
apt install wine-stable

Régebbi Wine PPA csomagtároló eltávolítása

Régebbi stabil Wine kiadás eltávolítása

A stabil Wine PPA csomagtároló eltávolítása a Szoftverforrásokban:

ppa:ubuntu-wine/ppa

vagy parancssorból a következő parancsokkal:

sudo add-apt-repository --remove ppa:ubuntu-wine/ppa
sudo apt update

Régebbi fejlesztői staging Wine kiadás eltávolítása

A fejlesztői staging Wine PPA csomagtároló eltávolítása a Szoftverforrásokban:

ppa:wine/wine-builds

vagy parancssorból a következő parancsokkal:

sudo add-apt-repository --remove ppa:wine/wine-builds
sudo apt update

További disztribúciókhoz szánt csomagok

  • Ubuntu - WineHQ bináris csomagok: Ubuntu 14.04, 16.04, 16.10, 17.04, és 17.10;
  • Debian - WineHQ bináris csomagok: Debian Wheezy, Jessie, Stretch, Buster, és Sid;
  • Fedora - WineHQ bináris csomagok: Fedora 24, 25, és 2;
  • Mageia - WineHQ bibináris csomagok: Mageia;
  • macOS - WineHQ bináris csomagok: macOS 10.8 és újabbakhoz.

Jó borozást!

Hozzászólások

medard képe

Kérdés

Miért nem lehet egy ékegyszerű leírást készíteni?!

medard@medard-Latitude-E4300 ~ $ apt install wine-stable
[sudo] password for medard:
E: 2. bejegyzés rosszul formált a(z) list /etc/apt/sources.list.d/additional-repositories.list fájlban (Component)
E: A források listája olvashatatlan.
E: 2. bejegyzés rosszul formált a(z) list /etc/apt/sources.list.d/additional-repositories.list fájlban (Component)
E: A források listája olvashatatlan.
medard@medard-Latitude-E4300 ~ $
 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Kérdés

@#1 Másold ide a parancs futtatása után megjelenő teljes szöveget.

Két módszer erre:

-- terminálból

cat /etc/apt/sources.list.d/additional-repositories.list

-- grafikusan

xdg-open /etc/apt/sources.list.d/additional-repositories.list

Értékelés: 

0
Még nincs értékelve

Kérdés

@#1.1 Ugyan nem én kérdeztem, de 18.3 Cinnamon:

[andrea@andrea-pc sources.list.d]$ cat: /etc/apt/sources.list.d/additional-repositories.list: Nincs ilyen fájl vagy könyvtár
 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Kérdés

@#1.1.1Hát igen, a fájl csak azon rendszeren létezik, ahol PPA-t felvettek valaha is. Nálad nincs PPA ezek szerint (vagy, ha mégis, máshogyan, máshova tetted be a tükör címét). A fájl a külső tárolók megszokott helye, elhelyezése (Linux Mint alatt persze).

 

Értékelés: 

0
Még nincs értékelve

Kérdés

Szia!

Sajnos én sem boldogultam a tároló hozzáadásával. A kapott kimenetek a következők:

 

@page { margin: 2cm }
p { margin-bottom: 0.25cm; line-height: 120% }

--2018-01-26 13:46:26-- https://dl.winehq.org/wine-builds/Release.key

dl.winehq.org (dl.winehq.org) feloldása… 151.101.12.69

Csatlakozás a következőhöz: dl.winehq.org (dl.winehq.org)[151.101.12.69]:443… kapcsolódva.

HTTP kérés elküldve, várakozás válaszra… 200 OK

Hossz: 3122 (3,0K) [application/pgp-keys]

Mentés ide: „Release.key.1”

 

Release.key.1 100%[=====================================================================================>] 3,05K --.-KB/s itt: 0s

 

2018-01-26 13:46:26 (38,0 MB/s) -- „Release.key.1” mentve [3122/3122]

 

harsanyi_mint_zoltan@SATELLITE-L855 ~ $ sudo apt-key add Release.key.1

[sudo] harsanyi_mint_zoltan jelszava:

OK

harsanyi_mint_zoltan@SATELLITE-L855 ~ $ sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/

harsanyi_mint_zoltan@SATELLITE-L855 ~ $ apt install wine-stable

Csomaglisták olvasása... Kész

Függőségi fa építése

Állapotinformációk olvasása... Kész

E: Ez a csomag nem található: wine-stable

harsanyi_mint_zoltan@SATELLITE-L855 ~ $ sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/'

harsanyi_mint_zoltan@SATELLITE-L855 ~ $ sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/ '

[sudo] harsanyi_mint_zoltan jelszava:

harsanyi_mint_zoltan@SATELLITE-L855 ~ $ sudo apt-get update

E: 7. bejegyzés rosszul formált a(z) list /etc/apt/sources.list.d/additional-repositories.list fájlban (Component)

E: A források listája olvashatatlan.

Segítségedet előre is köszönöm! Zoli 

Értékelés: 

0
Még nincs értékelve

Wine 3 Linux Mint-hez

Sikerült megtalálni a megfelelő információt Linux Mint-hez!

A Linux Mint 17x -en az utolsó sor a következő legyen:

 

sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ trusty main'

Linux Mint 18.x -en az utolsó sor a következő legyen:

sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main'

Értékelés: 

0
Még nincs értékelve
kimarite képe

Wine 3 Linux Mint-hez

@#3 Igen, mert a disztribúcióra jellemző 'trusty' vagy 'xenial' szó korábban lemaradt a PPA felvétele parancs sorból. ;)
Kicsit betegeskedem, viszont nagyon örülök, hogy a probléma megoldódott.

Értékelés: 

0
Még nincs értékelve
medard képe

A tároló hozzáadásánál lesz

A tároló hozzáadásánál lesz valami hiba, mert ott van valami link benne.

Próbáltam a Wine honlapján is kisilabizálni, hogy hogyan lehet hozzáadni a tárolót, de ott is ugyanilyen okosan van megoldva, hogy benne van a link a parancsban...

A linket követve megnyit valamilyen mappákat, abikben további mappák vannak és így tovább...

Értékelés: 

0
Még nincs értékelve
medard képe

Kérdés

Én továbbra sem tudom feltelepíteni...

Értékelés: 

0
Még nincs értékelve

Wine telepítés nem sikerült

 Sziasztok!

Nagyon kezdő Linuxos vagyok. Másodszor telepítettem fel a Mint-et (az első nem úgy sikerült ahogy kellett volna), első telepítéskor simán felment a wine, de most a másodiknál mindig vmilyen függőségi problémái vannak. Alapból ez az üzenet jelenik meg:

Csomaglisták olvasása... Kész
Függőségi fa építése       
Állapotinformációk olvasása... Kész
Néhány csomagot nem lehetett telepíteni. Ez azt jelentheti, hogy
egy lehetetlen állapotot kért, vagy ha az unstable disztribúciót
használja, akkor néhány igényelt csomag még nem készült el vagy ki
lett mozdítva az Incoming-ból.
Az alábbi információk segíthetnek megoldani a problémát:
 
Az alábbi csomagoknak teljesítetlen függőségei vannak:
 winehq-stable : Függ ettől: wine-stable (= 3.0.2~xenial)
E: A problémák nem javíthatók, sérült csomagokat fogott vissza.
 
Akkor beírtam a wine-stable telepítését, utána a következő:
 

Néhány csomagot nem lehetett telepíteni. Ez azt jelentheti, hogy
egy lehetetlen állapotot kért, vagy ha az unstable disztribúciót
használja, akkor néhány igényelt csomag még nem készült el vagy ki
lett mozdítva az Incoming-ból.
Az alábbi információk segíthetnek megoldani a problémát:
 
Az alábbi csomagoknak teljesítetlen függőségei vannak:
 wine-stable : Függ ettől: wine-stable-i386 (= 3.0.2~xenial)
E: A problémák nem javíthatók, sérült csomagokat fogott vissza.
 
Akkor beírtam annak a telepítését, mire egy csomó filet dobott ki. Esetleg vissza tudok menni az alaphelyzetre, hogy előről kezdjem, hátha mégis elrontottam vmit?
Előre is köszi.

Értékelés: 

0
Még nincs értékelve